MacAlert!

Up to the minute Apple and Mac news alerts

If You Own One of These Older Macs, Your Security May Be in Trouble

[2019-05-16 17:30:55]

First, it was Meltdown and Spectre. Now, it’s ZombieLoad. Suffice to say, there are a lot of scary-sounding vulnerabilities that bad actors would leverage to attack our Macs. Luckily, Apple is already on top of it. Even before news broke about ZombieLoad, Apple issued a handful of software updates that mitigate the vulnerability. (Which, by ......

If You Own One of These Older Macs, Your Security May Be in Trouble


Read more....



RELATED!

Using Chrome For Mac? Follow These Steps to Protect Yourself from ZombieLoad (Or Switch to Safari)

You Probably Had No Idea Your iPhone Was This Disgusting

iOS 12.4 Beta Shows You’ll Be Able to Set up Your Apple Card on an iPad

Former Apple Engineer Creates New UI Trick the iPhone Needs Right Now

Trump Expected to Sign Executive Order Banning Huawei Tech in the U.S.

Uber’s New Feature Lets Your Driver Know It’s Time to Stop Talking

FCC Reveals Plan to Block Annoying Robocalls Automatically (for Free)

The Games on Your iPhone Could Be Sharing More Personal Data Than Even Their Developers Realize

You Can Now Use Apple Pay for iTunes and the App Store (Here’s How to Set It Up)

5 Things You Should Know about ‘ZombieLoad’, the Latest Major Security Vulnerability on the Block

True or False? Some of These iPhone Battery Myths Are Factual

More Evidence Hints Next-Gen iPhone XR Will Come in Green and Lavender

Why Russia Is Spreading State-Funded 5G Fake News in the U.S.

Why Russia Is Spreading State-Funded 5G Fake News in the U.S.

4+ New Features and Updates in watchOS 5.2.1